Skip to content

Update to VPN Cisco Anyconnect software required

cisco.jpg
Due to the current upgrade of the George Washington University VPN system, users will be required to update their version of Cisco Anyconnect software to Version 4.5. If you are installing and logging into your GW VPN for the first time the software update will happen automatically after connecting.
Users currently running Cisco Anyconnect version 3.1 may have difficulty upgrading their software version and will need to uninstall the current version of Cisco Anyconnect, and download the current available version located at https://it.gwu.edu/virtual-private-network-vpn.
If you need assistance uninstalling the legacy version of Cisco Anyconnect VPN software or updating to the newest version, please contact the GW IT Support Center at 202-994-4948 or via email at ithelp@gwu.edu for further assistance.
Need help accessing Himmelfarb Library's online collections?  Please consult our step-by-step off-campus access instructions!

Leave a Reply

Your email address will not be published. Required fields are marked *

GW is committed to digital accessibility. If you experience a barrier that affects your ability to access content on this page, let us know via the Accessibility Feedback Form.